Nouveaux participants : profitez actuellement d’une promotion sur nos formations complètes Excel et Power BI 

Excel : la formation complète

Débutant à expérimenté : développez vos compétences numériques et apprenez à maîtriser  : Microsoft Excel

Power BI : la formation complète

Débutant à expérimenté : développez vos compétences numériques et apprenez à maîtriser  : Microsoft Power BI

Comment faire plusieurs SI dans Excel – combinaisons de Si – SI imbriqués

Sommaire

Dans cet article nous allons voir comment simplement et rapidement imbriqués des SI dans Excel.

La combinaison de fonctions SI dans Excel

Pour effectuer des tests logiques et afficher un résultat selon que le test est vrai ou faux, vous pouvez utiliser la fonction “SI” d’Excel. Vous pouvez imbriquer plusieurs fonctions “SI” pour exécuter plusieurs tests logiques.

Voici la syntaxe de base de la fonction “SI” :

SI(test logique; valeur si vrai; valeur si faux)

Par exemple, si vous souhaitez afficher “X” si une cellule contient un nombre supérieur à 100 et “Y” si elle contient un nombre égal ou inférieur à 100, vous pouvez utiliser la formule ci-dessous :

=SI(A1>100; “X”; “Y”)

Vous pouvez utiliser la formule suivante pour imbriquer de nombreuses fonctions SI :

=SI(test logique1; valeur si vrai1; SI(test logique2; valeur si vrai2; valeur si faux2))

Par exemple, si vous voulez afficher “X” si une cellule contient un nombre supérieur à 90, “Y” si une cellule contient un nombre supérieur à 50 et inférieur ou égal à 90, et “Z” si une cellule contient un nombre inférieur ou égal à 50, vous pouvez utiliser la formule suivante :

=SI(A1>90; “X”, SI(A1>50; “Y”; “Z”))

Vous pouvez effectuer des tests logiques plus complexes en combinant la fonction “SI” avec des fonctions qui renvoient un résultat vrai ou faux. Par exemple, vous pouvez utiliser la formule suivante pour déterminer si une cellule contient une valeur supérieure à 10 et inférieure à 20 :

=SI(ET(A1>10; A1<20); “X”; “Y”)

Depuis office 2016, vous pouvez utiliser la fonction SI.CONDITIONS pour imbriquer des SI : un article sur cette fonction

Merci d’avoir lu notre article, de plus si vous souhaitez apprendre à maitriser l’outil Excel de manière complète, vous pouvez vous perfectionner sur Microsoft Excel à l’aide de notre formation complète.

Vous pouvez aussi retrouver toutes nos formations (Excel, Power BI, Tableau Desktop, Looker Studio…) afin de monter en compétences sur ces outils informatiques !

 

Partager l'article sur :

À lire également :

Formations complémentaires :

Apprenez et montez en compétences avec nos meilleurs formateurs spécialisés en Business Intelligence. Nous vous conseillons la formation complète sur l’outil Microsoft Excel ainsi que sur l’outil Microsoft Power BI afin de maitriser au mieux vos données. 

Toutes nos formations peuvent être suivies quand vous le souhaitez, où que vous soyez. De plus, si vous vous posez une question au cours d’une formation vous pouvez contacter un formateur par mail qui s’efforcera de répondre rapidement.

Nos formations disposent de vidéos de grande qualité et d’un expert spécialisé dans le domaine afin de vous garantir la meilleure expérience possible.

Voici quelques avis récents sur nos formations :

Sur Espritacademique.com formez-vous en ligne à votre rythme, où que vous soyez sur les outils leaders du marché en informatique décisionnelle.

Recevez nos articles et tutoriels gratuitement sur Excel et Power BI directement dans votre boîte de réception :

S’abonner
Notification pour
guest
0 Commentaires
Commentaires en ligne
Afficher tous les commentaires

Boostez vos compétences sur Excel et devenez un expert en un clic :