Nouveaux participants : profitez actuellement d’une promotion sur nos formations complètes Excel et Power BI 

Excel : la formation complète

Débutant à expérimenté : développez vos compétences numériques et apprenez à maîtriser  : Microsoft Excel

Power BI : la formation complète

Débutant à expérimenté : développez vos compétences numériques et apprenez à maîtriser  : Microsoft Power BI

Fonction Excel SWITCH : Si multiple avec opérateurs

Fonction Excel SWITCH : Si multiple avec opérateurs

Sommaire

Ce qu’il faut savoir :

La fonction SWITCH n’est pas directement compatible avec les opérateurs dans Excel. SWITCH est conçu pour comparer une valeur unique avec une liste de valeurs et renvoyer des résultats basés sur la correspondance. Il ne prend pas en charge l’utilisation d’opérateurs.

Toutefois, si vous devez effectuer des comparaisons complexes à l’aide d’opérateurs, vous pouvez utiliser une combinaison de la fonction IF et d’opérateurs logiques (tels que AND, OR) pour obtenir le résultat souhaité. Voici un exemple de la façon dont vous pouvez procéder :

Disons que vous avez la cellule A1 contenant la valeur que vous souhaitez comparer. Vous souhaitez obtenir des résultats basés sur les conditions suivantes :

Si A1 est supérieur à 10 et inférieur à 20, renvoyez « Entre 10 et 20 ».
Si A1 est supérieur ou égal à 20, renvoyez « Supérieur ou égal à 20 ».
Sinon, renvoie « Moins de 10 ».

Vous pouvez utiliser la formule suivante :

=SI(ET(A1>10, A1=20, “Supérieur ou égal à 20”, “Inférieur à 10”))
Cette formule commence par tester la première condition avec l’opérateur AND, puis passe à la deuxième condition avec la deuxième fonction IF. Si aucune des conditions précédentes n’est remplie, la formule renvoie « Moins de 10 ». N’oubliez pas d’ajuster cette formule en fonction de vos propres conditions et opérations nécessaires.

Partager l'article sur :

À lire également :

Formations complémentaires :

Apprenez et montez en compétences avec nos meilleurs formateurs spécialisés en Business Intelligence. Nous vous conseillons la formation complète sur l’outil Microsoft Excel ainsi que sur l’outil Microsoft Power BI afin de maitriser au mieux vos données. 

Toutes nos formations peuvent être suivies quand vous le souhaitez, où que vous soyez. De plus, si vous vous posez une question au cours d’une formation vous pouvez contacter un formateur par mail qui s’efforcera de répondre rapidement.

Nos formations disposent de vidéos de grande qualité et d’un expert spécialisé dans le domaine afin de vous garantir la meilleure expérience possible.

Voici quelques avis récents sur nos formations :

Sur Espritacademique.com formez-vous en ligne à votre rythme, où que vous soyez sur les outils leaders du marché en informatique décisionnelle.

Recevez nos articles et tutoriels gratuitement sur Excel et Power BI directement dans votre boîte de réception :

S’abonner
Notification pour
guest
0 Commentaires
Commentaires en ligne
Afficher tous les commentaires

Boostez vos compétences sur Excel et devenez un expert en un clic :